waydock/flake.nix
2025-04-16 23:18:10 -04:00

24 lines
No EOL
683 B
Nix

{
description = "Universal dock for wayland compositors"
inputs = {
nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
};
outputs = inputs@{ flake-parts, ... }:
flake-parts.lib.mkFlake { inherit inputs; } {
systems = [
"x86_64-linux" "aarch64-linux"
];
perSystem = { config, self', inputs', pkgs, system, ... }: {
devShells.default = pkgs.mkShell {
packages = with pkgs; [
cmake
llvmPackages_19.clangUseLLVM
qt6.full
];
};
};
};
}